Scheduled for March 22, 2026 at 10:00 PM – March 23, 2026 at 4:00 AM
Affects
Boitekong
Under maintenance from 10:00 PM to 4:00 AM
Completed
March 23, 2026 at 4:00 AMCompleted
March 23, 2026 at 4:00 AMMaintenance has completed successfully
In progress
March 22, 2026 at 10:00 PMIn progress
March 22, 2026 at 10:00 PMMaintenance is now in progress
Planned
March 22, 2026 at 10:00 PMPlanned
March 22, 2026 at 10:00 PM🚨Net Nine Nine Maintenance🚨
Boitekong
Date: 23 March 2026, Monday
Time: 00:00 - 06:00
Please be advised that clients may experience service downtime during this period. Any delays or updates will be communicated promptly.